GT Heater Issue

Discussion in 'ELECTRICAL' started by Djaniero, Jan 27, 2019.

  1. Djaniero

    Djaniero Registered User +

    I had a search but couldn't really find an answer.
    My heaters in my GT get hot - thankfully - but regardless of what directional button I press, i.e face, legs, windscreen etc warm air only blows out of the single vent on the driver and passenger side... never the centre vents.
    I can hear the motor blower still working when the engine is off.
    Can anyone suggest what else could be causing the issue?

    Thanks
     
  2. SKINY

    SKINY Registered User +

    The flap on the box probably isn't working then, check all connections and motor getting power, also pull the control unit outs the dash check it too :)
     
    Jay likes this.
  3. Djaniero

    Djaniero Registered User +

    Thanks Skiny. Is the box flap an easy fix to repair?
    When texting the motor I just turned the ignition on and moved around the temp slider... I could hear the motor, but how else would I test? Sorry I'm crap with electrical stuff :(
     
  4. Jay

    Jay Admin

    There's two types of heater system - manual (operated by rods and cables) and electronic (wiring, motors and rods).

    Any idea with yours is?

    If the slider is just blue and red it should be the simple type, if it has numbers then it's fancy climatronic.
     
  5. SKINY

    SKINY Registered User +

    Mines that fancy one Jay, annoys me greatly it doesn't work with the a/c removed :oops:

    You should be able to get a look at the sides of the box to see what's happening bud
     
  6. dac69er

    dac69er Super Moderator

    it works fine with the a/c removed, apart from the fact that it cant cool due to their being no aircon.
    if i set a temp higher than the ambient in the car it will control to bring the temp up and then the fan will slow down and the heat will reduce automatically?
     
  7. SKINY

    SKINY Registered User +

    Maybe it's not then ? It's a slider like, with numbers above it.
     
  8. Djaniero

    Djaniero Registered User +

    Mines the fancy climatronic one Jay :rolleyes:.
     
  9. Jay

    Jay Admin

  10. SKINY

    SKINY Registered User +

    Right I'm confused again :rolleyes: mine has the buttons to change position and 2 sliders, is it the fancy one ?
     
  11. Djaniero

    Djaniero Registered User +

    Thanks a lot Jay. What usually goes wrong?....i.e. do the rods just come loose and need re-attaching?
     
  12. Calum122

    Calum122 Registered User +

    Yeah my brothers is like the fancy one, I guess I got the poverty model lol.
     
  13. Jay

    Jay Admin

    Usually the rods pop out of place but I've heard of a few motors messing about. That was years back though.

    Both systems use the same control panels. The climatronic one has temperatures on the slider bar just. This means you select the temperature and the heater aims to keep the cabin at it automatically.
     
    SKINY likes this.
  14. SKINY

    SKINY Registered User +

    Screenshot_20190201-163456_Gallery.jpg
    That the fancy one I have Jay lol
     
    Jay likes this.
  15. Djaniero

    Djaniero Registered User +

    You got the same "Posh One" as me SKINY lol
     
    SKINY likes this.
  16. Djaniero

    Djaniero Registered User +

    @SKINY did you get yours sorted in the end? I really need to get on the case and fix mine as I'm using the car over winter.

    @Jay Once I have removed the heater plastics etc will the rods be visible or are they in the passenger side foot well?

    Thanks lads:cool:
     
  17. SKINY

    SKINY Registered User +

    Yea bud should be pics in my thread off the dash removed etc, so is yours still blowing hot but not changing?
    My problem was I managed to completely fuck the blower moter and ac matrix out :Ddon't ask....
    Used it in the winter for a while like that and still got heat coming from the wee core lol, over 4 mile daily it was ok ish
     
  18. Djaniero

    Djaniero Registered User +

    Yeah man... Pretty much the case. Although it does'nt seem to be as hot as it was previously so maybe another flush is in order to get some sludge out.

    I'll have a look at your thread and see if I can figure it out.
     
  19. SKINY

    SKINY Registered User +

    Hardest part in removing the dash is the wiring loom clipped onto it bud, took me just over an hour first time then got it down to around 40 mins :)
     
  20. Djaniero

    Djaniero Registered User +

    Gutted :(. So there is no way to access the heater rods without removing the whole dash :(?
     

Share This Page