Strange fuel/ignition Cut

Discussion in 'Modification/ Technical Questions' started by suzieboy, Mar 14, 2019.

  1. gorganl2000

    gorganl2000 Registered User +

    if it's working leave it alone :cool:
    on my emanage ultimate i've never done a firmware update since installing it in 2007/2008
    and now based on your experience i never will...lol
     
    SKINY likes this.
  2. suzieboy

    suzieboy Fresh Recruit

    which firmware are you using?

    the only thing i want to swap back into the car is the 560cc injectors.
    Running stock injectors on the gt30 turbo on 15psi an above im running out of fuel.
     
  3. gorganl2000

    gorganl2000 Registered User +

    from what i can tell the version information states 2.0
     
  4. suzieboy

    suzieboy Fresh Recruit

    ok.

    So i updated the firmware to 2.33 an sure enough i got the problem again.

    I believe it has something to do with the scaling of injectors. Not quite sure.
     
  5. gorganl2000

    gorganl2000 Registered User +

    where are you getting this firmware from? any links?
     
  6. SKINY

    SKINY Registered User +

    Result then :) also another reason for me not to buy one...:rolleyes:
     
  7. Rev

    Rev Registered User +

    Plus
    Using the global injector setting for scaling larger injectors should include special mapping to prevent 100% Duty Cycle input from the stock ecu to the emu at higher boost, maybe someone will know if this changes with firmware?

    Short version of the emanage U Limitation -
    If a stock ecu goes 100% input duty cycle the emangeU can't control the injectors, as it has no gap or variation in duty cycle input data to calculate injector output. Usually this occurs at higher boost and usually results in afr going very rich.

    LINK : http://wheelsjamaica.com/wheels_forum/index.php?topic=76824.0
     
    Last edited: May 22, 2019
    Jay, suzieboy and SKINY like this.
  8. gorganl2000

    gorganl2000 Registered User +

    i've never had a problem with emu...and i've been using it for over 10 years on a 5efte with ct9, td04 and various versions of td05/vf35/etc with different injectors starlet 295cc/mazda 360cc & 460cc/subaru565cc
    i've seen this 100% duty in logs and it never affected anything---usually in 1st, 2nd and 3rd gears...it tends to smooth out in 4th gear.
    now i can't say for certain, but i suspect it has to do with the injector scaling parameters used and then that its a piggyback and is altering the stock ecu signals...tuners will tune emu/emb differently, in the scaling section some input original injector sizes and new injector sizes, some input lag times for the new and old injectors, some input both (which may differ), some input none, some input a combination...then proceed to tune accordingly....this could affect what you see in logging and how the emu/emb final fueling/ignition tune comes out. This aside, my car drives and operates like a stock car with this piggyback, the way it should be with any ecu ---no jerking/juddering, no running rich on idle or lean in the revs, no unexplainable map loss, etc

    10 plus years ago emanage was a good option for me over the preprogammed ecus (blitz, jam, sard, etc which can't be tuned and were/are very much overpriced), the very good/expensive standalones or cheaper/developing standalones at that time...and most importantly to me at the time, my tuner knew how to properly install and tune emanage (this is extremely important for any ecu you plan to choose and run in your car) and it used the stock sensors. Nowadays with the wider assortment and more affordable/developed standalones available which can use stock sensors, if i had to do it again, i'd probably choose one of these over emu. But as stated earlier, if it working, leave it alone---so emu remains for me.
     
    Jay likes this.
  9. suzieboy

    suzieboy Fresh Recruit

    Wow THIS makes alot of sense now. Kinda exactly what was happening. Duty cycle reach 100% an shuts off.

    Thanks.

    I re installed v 1.04 and car runs perfect again with stock injectors. I didnt use the scalling option.

    I cant recall were i got ver 2.33 from tho.

    The question i ask now. Whats the proper way to use emanage with 550cc injectors with the current firmware and the global scalling option?
     
  10. suzieboy

    suzieboy Fresh Recruit

    Hi guys so just a lil update; i reverted back to firmware 1.04 and i was successful in scaling the 550cc injectors. car idles an run perfect, no issues. I would like to run the newer firmware but this would do just fine for now.
     
    Fez and Jay like this.
  11. gorganl2000

    gorganl2000 Registered User +

    Glad to hear. I'd suggest that you stick with firmware 1.04 as its working for you.
    Yeah, emu is great if you can get it tuned correctly
     
  12. Rev

    Rev Registered User +

    x2 Good to hear larger injectors are behaving and are 'perfect'. What is your objective with newer firmware?
    Stock ecu chips won't go any faster :)
    Net shows lots of issues with firmware upgrades although some may also be improper connections that need soldering.
     
    Last edited: Jun 4, 2019
  13. suzieboy

    suzieboy Fresh Recruit

    well not necessarily the firmware but the program. However the newer program only works with newer firmware. With that i get knock sensor workin and other lil logging stuff. But other than that it works fine.
     
  14. Rev

    Rev Registered User +

    Great to have knock info.
    vs 2.33 e-manage-ultimate software download site says knock display is not available for some less popular vehicle models.
    2.33 download> https://en.trust-power.com/products/electronics/greddy-e-manage-ultimate/
     
    Last edited: Jun 7, 2019

Share This Page