dac69er's latest activity

  • dac69er
    dac69er replied to the thread Bloody waterpumps!!!!!!.
    maybe i will just have to go with genuine. im just surprised how poor the aftermarket ones i have used have been :( the coolant that...
  • dac69er
    dac69er replied to the thread Bloody waterpumps!!!!!!.
    I don't have a leak from where it bolts on, it's either from the little hole that tells you the rotary seal is leaking or from the shaft...
  • dac69er
    dac69er replied to the thread Bloody waterpumps!!!!!!.
    The rest of the system is 100% always use Toyota red coolant too. The pump is the bolt on pulley type, I have changed the pulley and...
  • dac69er
    dac69er posted the thread Bloody waterpumps!!!!!! in ENGINE.
    Has anyone else had issues with waterpumps leaking after only a short period of use? My runaround mk1 had a slight leak from the seal...
  • dac69er
    dac69er replied to the thread Parts for sale.
    3k worth of stuff you just forgot about sitting in the attic!?!?!?! Madness!
  • dac69er
    dac69er replied to the thread Air in coolant problem!?!?.
    I always smear a bit of engine oil on the seal. Never failed me before. I just think it was a cheap seal that was the problem! My rx8...
  • dac69er
    dac69er replied to the thread Gearbox synchros?.
    I've always found the comma stuff good. I quite like tripleqx stuff from ecp too. As I had spent so much on the box I wanted to put the...
  • dac69er
    dac69er replied to the thread Gearbox synchros?.
    I used that comma oil as my "flushing" oil when I first fitted the box. I ran it for a few 100 miles then drained it out and put the...
  • dac69er
    dac69er replied to the thread Gearbox synchros?.
    Selectors and bushes are perfect and well lubricated. When warmed up it is perfect and it's fine 90% of the time when cold. Tbh, I...
  • dac69er
    dac69er replied to the thread Air in coolant problem!?!?.
    It was a non genuine seal. I have now fitted a genuine seal and it's all back together. Time will tell whether it is fixed
  • dac69er
    dac69er replied to the thread Gearbox synchros?.
    Every now and again when cold you will get the odd baulky gearchange. It doesn't crunch. Perhaps it's just how these boxes are as they...
  • dac69er
    dac69er replied to the thread Air in coolant problem!?!?.
    Well over time it has sorted itself. I don't get the issue anymore anyway. Odd i have never had an issue before. Have a leak from the...
  • dac69er
    dac69er replied to the thread Gearbox synchros?.
    It was an ep82 c52 box. I'm not 100% convinced it's perfect, but it seems a lot better than it was.
  • dac69er
    dac69er replied to the thread Air in coolant problem!?!?.
    This particular gt is all fairly stock and as I said, never had any issues before! Idle is fine so seems like there is no air in that...
  • dac69er
    dac69er replied to the thread Air in coolant problem!?!?.
    Small possibility I guess, but as the expansion bottle is raising and dropping as it should with no boiling over issue etc, I would say...
Top