EP82 rpm not working


Member +
Hy guys. Iv got a 95 ep82 soleil l and converted it to a 4efte. Decided to change the cluster from the old non rpm to one that has the rpm dials. Got everything to work except the rpm, iv tapped a wire from the IGf on the ecu and also tried from thw lls (rpm) from ecu but it doesnt work. If tried on a defi tacho that i have it works perfect. I measured the voltage and its giving me a 0.80 reading( not sure if this is what it should be) What could be the issue? Iv tried practically everything i can think of


Super Moderator
Have you got all the other pin positions correct on the new dials?

When I swapped mine I had to swap a few of the wires round on the plug connections as well as adding in the additional wire for the rpm.


Member +
Yes all other pins are correct. From fuel signal to temp signal are all working. All the lights are good as well. Read a thread some time back on resostors could it be the case?


Member +
I figured it out. My soleil didnt come standard with RPM Cluster and in so there was no RPM signal. So what i did: Tapped with a shielded core wire from AC Computer to the GT Cluster and it works. I have a lot of electrical problems with my car but it works.
  • Like
Reactions: Jay