bad misfire

Discussion in 'ELECTRICAL' started by H_D, Jun 26, 2019.

  1. H_D

    H_D Paid Member

    Keep getting a really bad misfire when it rains, no water is getting into my engine bay at all. I have changed the plugs, dizzy cap and rotar arm, added extra earths to the coil and ignitor but no luck.
    Any suggestions
     
  2. H_D

    H_D Paid Member

    btw - im still using the same blitz ignition leads that came with the car when I got it 10 years ago, the still look like new and cant see and rips/cuts/tears in them and they still have a tight seal, I was told they are supposed to last a lifetime?
     
  3. SKINY

    SKINY Registered User +

    I had this happen, vaseline round your plug holes to make sure they are sealed up, was the legend Jay told me, never happened again in the pish :cool:
     
    Jay and H_D like this.
  4. SWJ

    SWJ Member

    Well who is to say .. how long a lifetime is??? But an easy way to see if the wires are leaking, is to fire the motor up at night and look at them. If they are really bad ... they will light up like a Christmas tree at night! :)

    Short of that the Vaseline couldn't hurt but I'd also unhook everything you can, on the ignition and spray it with WD 40, as it displaces moisture!
     
    Jay and SKINY like this.
  5. H_D

    H_D Paid Member

    Got some new ngk leads and the missfire is gone. Also found the fault with my old blitz leads and fixed them up. So il just keep them as spares.
     
    SKINY and Jay like this.
  6. SWJ

    SWJ Member

    LOL, well that one was easy! :)
     

Share This Page