Problem with electronics (I think)

Discussion in 'ELECTRICAL' started by EP91_Starlet, Mar 1, 2020.

  1. EP91_Starlet

    EP91_Starlet Fresh Recruit

    First post here, I'll introduce myself.

    My name is Coen, and I'm 21 years old, living in The Netherlands. I drive a green Toyota Starlet (EP91).

    So here's my problem:

    I bought a 4E-FTE from Groundspeed (very known company in NL), and swapped that one in my red EP91 and drove that around for about a year. I decided to buy another, better looking Starlet, a green EP91, and swapped my 4E-FTE into that one. It was all plug&play, and it cranks now, but doesn't fire up, and I really don't know why. I used the exact same loom as in the red Starlet, and soldered the same plug to the same wires, which Groundspeed told me to do.

    I checked every wire from the distributor cap, the ignitor and the coil to the ECU, and they aren't broken or something, all 0 Ohm. I have a 4E-FTE A/T ECU, which camewith the engine, and worked fine, also tried a manual 4E-FTE ECU, but that doesn't make any difference.

    I did swap the complete steering colum, and steering house, because the red one didn't have power steering, and the green one did. So I decided to get rid of the powersteering. But the ignition switch came out of the red one, so it should work I guess.

    I work at Louwman, a Toyota dealer/importer in The Netherlands, and my colleagues can't figure it out either, so I'm really lost right now..

    Is there any kind of immobilizer I don't know about? Or something else I should check?

    Hope that one of you can help me with this problem. Any help is very appreciated!
     
  2. Jay

    Jay Admin

    Welcome to the site man, hope it proves worthwhile reading.

    With regards to your starting issues it could be a great number of things. First thing I'd do is triple check everything just in case it's (hopefully) something simple. In terms of simple you've probably already checked the basics (fuel/air/compression/spark). Also worth taking a look at the fuses in case something got shorted during the swap over.

    Few questions first :

    When you say it doesn't fire up, do you mean it is completely dead, turns over or starts then cuts out?

    Are both EP91's the same? (year, spec, ECU, etc)

    I don't know about NL EP91's but the UK ones came with an immobilizer as standard. It uses a transponder chip in the key so might be a factor - I've seen conversions with the original key taped to the barrel before o_O

    Jay
     
    Last edited: Mar 1, 2020
    Calum122 likes this.
  3. EP91_Starlet

    EP91_Starlet Fresh Recruit

    Hi Jay,

    Thanks for your answer. I do have compression and air, just no spark and fuel. I checked the fuses, and the EFI fuse (15A) was shorted, so I replaced it,still no live.

    The engine does crank, but doesn't fire up. I swapped the entire steering column, and didn't see any immobilizer. If I have one, where could I find it? I tried both steering columns, but it didn't make any difference.
     
  4. SKINY

    SKINY Registered User +

    Try holding the different keys you have on the barrel when trying it bud :) I'm thinking immobiliser too
     
  5. EP91_Starlet

    EP91_Starlet Fresh Recruit

    All the keys are on the keychain, so I’ve tried that..
     
  6. Rev

    Rev Registered User +

    Very random but I found on a safety switch on Sera break pedal stops engine starting when brake light doesn't work this routes through the hazard lights and bad hazard contacts can break the circuit. I wonder if you have a similar safety feature in the EP91 circuit?
     
    Calum122 and SKINY like this.
  7. SKINY

    SKINY Registered User +

    Is that on an auto Rev ? Probably a safety thing, the Dina wont let me start it if it's not in Park, think that's why the keys take a beating
     
  8. Rev

    Rev Registered User +

    Yea Auto. I discovered this when rubber grommet on the brake switch cracked and fell out and I think the switch contact was lost when you do the touch brake start engine routine.
     
    SKINY likes this.

Share This Page