power steering getting hard

azerty

Supermoderator
Hello,

Has anyone has noticed an isue with power steering getting hard on some occasion ?
What could be the reason ?
 

Jay

Admin
Haven't experienced anything other than a slipping belt (and you'd definitely hear it).

Original pump and rack?
 

SKINY

Lifer
Wear and tear I'd say Leo, id try flushing the fluid with new stuff then look at the pump if the racks ok
 
  • Like
Reactions: Jay

azerty

Supermoderator
Check the 2 little air pipes on the steering rack,low idle doesn't help.
what should be check on those ? where do they go ? I don't enven remember if I have those.

I have tried 3 mecanical pump, and 5 hydraulic/electric pump. 3 steering rack, semi synth DEXTRON and full synth ATF fluid without sucess !!
 

dac69er

Super Moderator
tight UJ?

This is a common problem on the RX8, but it is in the engine bay near the exhaust. Worth a look though.

Is it tight one way, or just in a certain place?
 

Jay

Admin
True enough, the MR-S suffer from corroded UJ's. I've to tackle the one on mine before it gives any hassle.

Worth a look!
 

azerty

Supermoderator
tight UJ?

This is a common problem on the RX8, but it is in the engine bay near the exhaust. Worth a look though.

Is it tight one way, or just in a certain place?
Could check that. I would think it has more to do with hydraulic system failing to operate properly at some point. Heat, Pressure valve, a combinaison of factors. As I said, when starting the car it is all fine at start. then after some time during racing it becomes freaking heavy
 

Fizturbo

Member +
what should be check on those ? where do they go ? I don't enven remember if I have those.

I have tried 3 mecanical pump, and 5 hydraulic/electric pump. 3 steering rack, semi synth DEXTRON and full synth ATF fluid without sucess !!
Pipe on rack helps idles the engine up when power steering pump strains, 1 goes to the vacuum rail on inlet manifold and other to throttle vac.
 

dac69er

Super Moderator
As I said, when starting the car it is all fine at start. then after some time during racing it becomes freaking heavy
You never mentioned any of that to begin with!!!!!

Are you revving any higher than normal? Are you using stock sized pulleys?
 
what should be check on those ? where do they go ? I don't enven remember if I have those.

I have tried 3 mecanical pump, and 5 hydraulic/electric pump. 3 steering rack, semi synth DEXTRON and full synth ATF fluid without sucess !!
Lionel, at this point i'm lost as to the cause of your issue,
i can't see it being any of those items now, so we have to look elsewhere or something mechanical which is connected....steering column?---but i dont think there's anything in there to seize/tighten up
could the extreme heat from the manifold/turbo be affecting the PS pump after a long pull? causing the fluid to run hot or bypass something or drop pressure? just taking some wild guesses here....PS oil cooler???.....but then again ppl track these cars without PS issues so that's questionable
 

SKINY

Lifer
Completely stabbing in the dark here,
What if it's the belt heating up and expanding a bit, hence reducing the pump pressure
Give it a nip up and see ? :)
 

azerty

Supermoderator
You never mentioned any of that to begin with!!!!!

Are you revving any higher than normal? Are you using stock sized pulleys?
you are right. I have been talking about this issue so much around me that I though I wrote it, sorry :rolleyes: I'm getting old :p
 

azerty

Supermoderator
Lionel, at this point i'm lost as to the cause of your issue,
i can't see it being any of those items now, so we have to look elsewhere or something mechanical which is connected....steering column?---but i dont think there's anything in there to seize/tighten up
could the extreme heat from the manifold/turbo be affecting the PS pump after a long pull? causing the fluid to run hot or bypass something or drop pressure? just taking some wild guesses here....PS oil cooler???.....but then again ppl track these cars without PS issues so that's questionable
Heating has been one of my though. I think there are few factors and that one could definitly be one of the cause. I tried a cooler (I have a cooler inside my water rad) but didn't change anything.
 
Heating has been one of my though. I think there are few factors and that one could definitly be one of the cause. I tried a cooler (I have a cooler inside my water rad) but didn't change anything.
do you mean like the automatic transmission cooler at the bottom of the stock radiator on an automatic ep91/ep82??? if so, i've always wondered how effective they really are ---hot ATF, hot coolant, hot radiator, hot manifold, hot downpipe...but it's just something in the back of my mind, who knows??!!
when i mentioned PS cooler earlier i was referring to an independent unit---similar to an oil cooler
 
Top