White Smoke....???

jjayokocha

Ulster Area Rep
Strange, but since Jay showed me how to bridge the fan so it doesnt run all the time the white smoke seems to have stopped now. Cheers for that Jay lol
 

dan_91

Member +
well good news guys... after a few chats with my faTHER i showed him what i meant. and started rememberin i hadnt boosted for a while as tryin too save fuel.. so took it for a good thrashin up the motorway and it has cleared and not doin it al. not even the smell. back t the smell of good ol petrol :)
 

SWJ

Member
Not the same car but I have a 92 Tercel original valve stemp seals. So I am well aware of smoke at idle. Like some of the guys said it could be normal,

But if it's blue smoke at idle only, it's the valve guides, white smoke while running, last time I saw that 85.5 944, headgasket. Blue smoke while under load, rings. These are just general observations not turbo specific.
If it's only at idle your most likely ok but keep an eye out for your water level!
 
Last edited:

RGM1800

Member +
well good news guys... after a few chats with my faTHER i showed him what i meant. and started rememberin i hadnt boosted for a while as tryin too save fuel.. so took it for a good thrashin up the motorway and it has cleared and not doin it al. not even the smell. back t the smell of good ol petrol :)
did it cleared the smoke?
 

Johnboy GT

Member +
Im afraid to say i too am in this boat. When im sat in traffic, my car starts to smoke like a bluey kinda colour, seems to clear itself as soon as you move off. be she is using quite a bit of oil. i thought it was either stem seals or turbo. this was all before she was takin off the road for the winter. pickin up a fresh turbo in the next few weeks and im hopin this cures her.. anybody like to add?
 

mickP95

Member +
my one is doing the same.its in the garage at the monent its either the turbo seals or the oil seals. should hav it bk tomorrow wit them doin so i can let yea now tomorrow.you shoud always do the both of them its one or the other caused wen yea hav them apart its the easiest to the two
 

jjayokocha

Ulster Area Rep
my one is doing the same.its in the garage at the monent its either the turbo seals or the oil seals. should hav it bk tomorrow wit them doin so i can let yea now tomorrow.you shoud always do the both of them its one or the other caused wen yea hav them apart its the easiest to the two
how much you getting charged for them gettin done?
 

Ant

Member +
Snap..same thing for me too.

Mine is also smoking. None on startup or general driving, but when letting the pedal off to brake/slow down I get a little cloud of stinking white smoke. Really stinks bad!

I see there was a post further back where their car had been run off boost for a week or so, I've just had to do this so I'm wondering if it's the same thing? maybe just needs a good caning up the road to clear it.

I'll have to keep an eye on the oil level & see if it stops smoking & post an update soon.

Ant.
 

Kushal

Member +
check ur PCV valve.

had the same prob few days back..

changed 2 turbos..check compression...
but was still doing white smoke..

then i removed my oil catch tank..n went back to stock setup..
all white smoke was gone after 15km of drivin
 

Ant

Member +
The PCV valve is new, the catch can is now defunct as I've had a race spec rocker fitted yesterday, a (new) hybrid CT9 2 weeks back. I noticed the first cloud at the start of the week, and over the last couple of days it's gotten more frequent (not worse, with more smoke)

Anyone had the same problem?

It stinks really bad! I'm going to run it for a bit & keep an eye on the oil level.
 

HOK

Member +
white smoke= moisture or coolant entering the cylinder
blue smoke= oil entering the cylinder
black smoke= burning to much fuel, running rich

know this is basic but its always a good starting platform.:)
 

HOK

Member +
If oil is coming out of your dump valve, as your dump valve is on the air intake side your turbo seals may have gone, and if you are sucking in oil through your intake you will get the blue smoke as it will be getting burnt in the cylinder.
 

glanzaphil

Fresh Recruit
i noticed alot of white smoke from my glanza so took it for a pressure test and its the headgasket:mad: the only signs were white smoke and drinking a bit of water, fitting a uprated steel one this time at a bloody massive cost
 

shawzy

Member +
please som1 help us im now in this boat
i have smoke comin out and oil pumpin out roker cover pipe as well as
if i block roker cover pipe white/black/blue smoke pumps out of exhaust
iv changed turbo still the same and now started a ratterly noise on topend
what could this beeeeee???????
 

Dub-Se7en

Lifer
please som1 help us im now in this boat
i have smoke comin out and oil pumpin out roker cover pipe as well as
if i block roker cover pipe white/black/blue smoke pumps out of exhaust
iv changed turbo still the same and now started a ratterly noise on topend
what could this beeeeee???????
block off pcv valve (pipe from rocker to inlet) it could be stuck open and pressurising engine on boost
 

nickyb

Fresh Recruit
need help head gasket problems

hi just dne a head gasket on myglanza this week using tm- developments head set started it up for the first time 2day it ran fine 4 5 minutes then it started 2 smoke alot of white smoke then misfire going from 4 to 3 cylinders u rev it lots of white smoke miss fire goes but lot of white smoke do u think head gasket incorrect and pumpin coolant into cylinder p,lease can anyone help ?????
 

Glanza-Dan

Fresh Recruit
Just noticed some white smoke coming from the exhaust on my glanza recently, only when its on idle and when I give it a slight rev...

Any idea what this is??

Thanks, John
ive recently baught a glanza and have this problem... i have a leak between the brand manifold and the turbo .. and also the head gasket has gone... damn i got mugged off a treat :-( .. not saying you got the same problem but this is what ive come across and mine chucks out loads of white smoke..
 

paddy98

Fresh Recruit
i'm getting smoke out of my exhuast but its def not the cold.

basically i can rev it and it is fine but as i ease off and let the revs run down ( as in driving in gear ) everything is fine but then if i go back on the throttle a big puff of whitish smoke comes out. what could this be.
i know it is using a bit of oil. is it anything to worry about or should i get it checked out. it runs fine though
ye man mines the exact same was jus wonderin what the problem was wit urs b4 i go change anythin! if you could get back to me it;d be great cheers
 
Top