Recent content by Zafar Ahmed

  1. Z

    Issues after installing HKS actuator

    Hey guys great news! Changed the plugs to NGK BKR7EIX (Heat range 7). The problem is solved and holding boost well around 11.5-12PSI in 3rd gear. Next on the list is the GReddy Profec OLED boost controller. Can I use the EBC to get 12.5PSI stable throughout all the gears?
  2. Z

    Issues after installing HKS actuator

    Hi guys. Got myself a new HKS actuator past week. Installed it as per to the given instructions. Set it to 123mm (0.8 bar) below fuel cut. Car boosts at 9psi 1st gear. 2nd gear 10-11psi but around 6k rpm the car just lets go for a split second feels like hitting the rev limiter once. Happens on...
  3. Z

    do all starlet turbos ep82 and ep91 have same lambda sensor

    Thanks lad. I switched mine from another 4efte. Did the job.
  4. Z

    do all starlet turbos ep82 and ep91 have same lambda sensor

    Hey chaps. Will any single wire 02 sensor work for the 4efte ep82? I'm running a decat if that makes a difference...
  5. Z

    OEM actuator boost

    I'll keep that in mind Jay. I believe right now I'm running slightly advanced timing. The last time I ran 10 degrees, it was as flat as a pancake. Any suggestion on that would be epic!
  6. Z

    OEM actuator boost

    Can I up the boost with stock actuator via manual boost controller? If I raise it to 12-13psi, what ignition timing should I run? Please note, fuel quality is utter garbage!
  7. Z

    Continuous idle issues!!!

    Thanks for your input jay. I'll trying switching the coolant temp sensor.
  8. Z

    Continuous idle issues!!!

    Thanks for your input bud. Cooling is in top shape.
  9. Z

    Continuous idle issues!!!

    1995 EP82 GT Turbo. For the life of me can't get to fix my idle. Idle drops to 500 rpms and alternator belt starts squeaking. Happens when coming to a stop specially after a spirited drive. Tried setting idle both from the throttle body screw and the throttle cable underneath the throttle...
  10. Z

    4efte smoking problem??

    you are using the wrong grade lad... try using 5w-30 or 5w-40 if you wanna go synthetic. or you may stick to the factory recommended at 10w-40 semi synthetic. cheers from Bangladesh!
  11. Z

    Low idle

    Hey guys. I have the same problem with the light. How do I adjust the TPS?
Top